[Vortex] Problems using win32 binaries.

Francis Brosnan Blazquez francis at aspl.es
Wed Aug 1 09:29:17 CEST 2007

> Hi,


> Sorry if this gets double posted, I used the wrong account the first
> time I sent it and didn't know if it would make it through.

No problem..

> I'm trying to use Vortex on Windows to evaluate it for some networking
> applications.
> I downloaded and ran the installer for the windows binaries:
> vortex-installer-1.0.3-w32.exe
> I then copied some sample code from the vortex site into my C++
> appliction and tried to comple it using Visual Studio. Note that I
> configured my project to point to the appropriate locations for
> include
> and lib files. The sample code includes the file "vortex.h".
> It seems that there are a number of missing dependencies in the
> include
> files: 
> First error: vortex.h includes the file glib.h which is not found. I
> read in one of the archived mailing list messages that glib dependency
> was removed so I thought this might be left over. I commented out this
> include and and tried again.

Looks like wrong header included by previous releases. I've checked
current vortex.h (1.0.5) and no longer includes <glib.h>.

> Next error: axl_decl.h includes the file axl_config.h which is not
> found. I searched for this and it's not part of the installation.
> Other files included but not available: unistd.h, axl_hash.h,
> axl_factory.h

I've checked the NSI definition used to build the Vortex package and it
doesn't includes axl_hash.h, axl_factory.h and axl_config.h. Now they
are included.

> Also note that when trying to run the vortex-client.exe,
> vortex-listener.exe, they fail to run due to missing
> libglib-2.0-0.dll.
> This dll is not provided by the installer.
> I then tried a previous version: vortex-installer-1.0-w32.exe
> This version includes the glib headers and libraries so I didn't get
> an
> error for glib.h
> Still missing unistd.h (included by axl_decl.h) and axl_hash.h
> (included
> by axl.h).

Looks like the installer have several issues. Let me check this issues
to publish new installers for latest version.

> I then get a list of redefinition errors from winsock.h

I would ask you to send this list but they are related to a old Vortex
version. Once you can check latest installers, let us to know them if

> Am I missing something obvious?

Not really. Installers provided at the SF.net are tested to properly run
(and they do). Looks like our building machine have the
libglib-2.0-0.dll installed on the path (that's why binary runs), erros
found by your compilers are understandable because we use GNU gcc on

> Note that I am not trying to build the library, I just want to use the
> prebuilt binaries.
> My understanding is that the Vortex library does not require cygwin or
> anything other than axl in order to run on windows. Is this correct?

That's right. Optionally it is required GNU SASL and OpenSSL to have
SASL and TLS BEEP profile support.

> Any help would be appreciated. Looks like a nice API but I'm not
> having
> much luck with it so far.

Thanks for your comments, 


> Thanks
> - MKane

Francis Brosnan Blazquez <francis at aspl.es>
Advanced Software Production Line, S.L.

More information about the Vortex mailing list