[Vortex] async connect issue on linux 2.4

Robert M. Münch robert.muench at robertmuench.de
Mon Oct 20 17:35:47 CEST 2008

Am 20.10.2008, 16:54 Uhr, schrieb Francis Brosnan Blazquez <francis at aspl.es>:

> One question: how did you solved this issue until now? Do you use 0 or 1
> directly rather false or true?
> In the other hand, I think this could it be solved by changing bool
> definition to use char. This will cause vortex and axl build to use a
> fixed single signed byte representation. It remains checking against a c
> ++ program but it should work.
> Another approach would be to remove the bool type definition from axl
> and vortex API. This is something we had in mind for some time, but then
> no more issues were found...maybe it is the moment to do so.

Hi, while you are at it, here is one point often not taken into account, even it's a rare one but if it happens extremly hard to track down. It's not ensured that you get: 0 = false and 1 = true in C/C++. The standard defines TRUE as != 0 So it could even be 255 (setting all bits for example). This is compiler implementation dependent.

If porting Vortex to more platforms is on the roadmap or other people doing it. They might be hit by code that requires TURE = 1.

Robert M. Münch
Mobile: +49 (177) 245 2802

More information about the Vortex mailing list