[Vortex] Vortex on Mac OS X

Francis Brosnan Blazquez francis at aspl.es
Mon Apr 5 09:50:59 CEST 2010

>         Hi,

Hi Adam,

>         I have been trying without success to get the Vortex library
>         to run on Mac OS X (10.6.3). At first I was unable to get it
>         to build at all, but with some archived messages from this
>         mailing list and some Google searching I have managed to get
>         it into a compiled and installed state. However it crashes
>         every time I attempt to run the listener regression test. This
>         is what the output looks like from gdb:
>         Starting
>         program: /Users/adamcox/Development/Vortex/svn/svn-vortex/test/.libs/vortex-regression-listener 
>         Reading symbols for shared
>         libraries .+++++++++++++++.......... done
>         ready and waiting..
>         Program received signal EXC_BAD_ACCESS, Could not access
>         memory.
>         Reason: KERN_PROTECTION_FAILURE at address: 0x00000000
>         [Switching to process 49688]
>         0xffff061a in __bzero ()
>         (gdb) bt
>         #0  0xffff061a in __bzero ()
>         #1  0x0002cbfd in __vortex_io_waiting_poll_clear
>         (__fd_group=0x404a20) at vortex_io.c:312
>         #2  0x0002f6b4 in __vortex_reader_run (ctx=0x800000) at
>         vortex_reader.c:1300
>         #3  0x987d7a19 in _pthread_start ()
>         #4  0x987d789e in thread_start ()

This is exactly the same error that was reported by Dave Dribin at:


..but it seems the solution was no reported.

>         Contrary to what the path says, this isn't an svn checkout,
>         it's the latest Vortex version from sourceforge (1.1.3). 


>         In order to get to a built state, I had to make a number of
>         modifications to the Makefile and source. 
>         In the Makefile I had to change the $PTHREAD_CFLAGS variable
>         to be empty instead of the string 'none'. I also had to set
>         the python builds to use only i386 instead of also building
>         x86_64 and ppc.

Could you post those modifications Adam?

>         In the source files I corrected a number of warnings, mostly
>         printf statements without formatting strings. I also corrected
>         formatting strings where the arguments were of a different
>         type due to platform differences (e.g. off_t is 64 bit on OS
>         X).

I think this issues are already fixed on svn. Maybe you can also post
this changes to check if they can be integrated into SVN.

>         I have tried using the Makefile from the previous OS X thread
>         with no luck either.
>         Has anyone else had more luck that me in getting this to work?

We have reports from users using Vortex on Mac OS/X without problems
(but using Xcode). The interesting thing of your backtrace is that
__vortex_io_waiting_poll_clear receives a valid __fd_group (0x404a20),
or at least something not pointing to 0x0 (contrary to Dave Dribin

I'd recommend breaking on __vortex_io_w4aiting_poll_clear and display
poll variable content. You could try something like:

(gdb) b __vortex_io_waiting_poll_clear
(gdb) run
(* once reached poll_clear *)
(gdb) n
(gdb) display poll
(gdb) display poll->length
(gdb) display poll->set
(gdb) display poll->max

...you'll have to adapt these instructions to your context. 

The other misterios thing is that bzero is called rather than memset
(which is what is placed on the code). Maybe this is what is causing
these builds to fail...:-?

Give a try let us to know your progress.

We have planned to release 1.1.4 soon to include latest changes. Cheers!

>         Thanks in advance for any help you may be able to provide.
>         Kind Regards,
>         Adam
Francis Brosnan Blazquez <francis at aspl.es>

More information about the Vortex mailing list