[Axl] Link errors on OS X

Dave Dribin dave-ml at dribin.org
Tue Apr 29 16:21:38 CEST 2008

On Apr 29, 2008, at 3:41 AM, Francis Brosnan Blazquez wrote:
> ...;-? It is possible Makefile(.in) files aren't refreshed with  
> changes
> introduced, or they were refreshed but those sentences wasn't applied
> for some reason.

Nope, I ran make maintainer-clean and autogen.sh so they were fresh.   
Using libaxl_ns_la_LIBADD instead of libaxl_ns_LDADD seems to work.   
Patch attached.

> It is also estrange the compiler is mangling function
> reference from axl_calloc to _axl_calloc.

Adding an underscore to C symbols is fairly common.  I thought Solaris  
uses it, too (are at least used to).

Okay, it all builds now.  Haven't tried installing it and using it  
with Vortex yet (my ultimate goal).


-------------- next part --------------
A non-text attachment was scrubbed...
Name: axl-osx.patch
Type: application/octet-stream
Size: 944 bytes
Desc: not available
Url : http://lists.aspl.es/pipermail/axl/attachments/20080429/ded7f68c/attachment.obj 
-------------- next part --------------

More information about the Axl mailing list