[Axl] Link errors on OS X

Francis Brosnan Blazquez francis at aspl.es
Tue Apr 29 17:08:27 CEST 2008

Hi Dave,

> On Apr 29, 2008, at 3:41 AM, Francis Brosnan Blazquez wrote:
> > ...;-? It is possible Makefile(.in) files aren't refreshed with  
> > changes
> > introduced, or they were refreshed but those sentences wasn't
> applied
> > for some reason.
> Nope, I ran make maintainer-clean and autogen.sh so they were
> fresh.   
> Using libaxl_ns_la_LIBADD instead of libaxl_ns_LDADD seems to work.   
> Patch attached.


> > It is also estrange the compiler is mangling function
> > reference from axl_calloc to _axl_calloc.
> Adding an underscore to C symbols is fairly common.  I thought
> Solaris  
> uses it, too (are at least used to).

Good to know it. Currently vortex only export symbols starting with
vortex or __vortex .... I supposed no C compiler mangles function

> Okay, it all builds now.  Haven't tried installing it and using it  
> with Vortex yet (my ultimate goal).

Good, but did your change (libaxl_sn_la_LIBADD) solve the issue or did
it updating export-symbols-regex to include a "_axl" prefix? 


> -Dave
Francis Brosnan Blazquez <francis at aspl.es>
Advanced Software Production Line, S.L.

More information about the Axl mailing list